Input

book: Create a structured PDF document with headings, chapters, etc.
webpage: Specifies that the HTML sources are unstructured (plain web pages.) A page break is inserted between each file or URL in the output.
continuous: Specifies that the HTML sources are unstructured (plain web pages.) No page breaks are inserted between each file or URL in the output.
Title of the document for the front page.
Extract the first heading of the document and use it as title. If checked the title field has no effect.
The title image or HTML page. These file has to be an attachments!
Specify document version to be displayed on the title page.
Intellectual property owner of this document.
Copyright notice for this document.
Information about who and when modified the document are applied at the end.

Output

Specifies the output format.
Grayscale document  Title page
Compression :   JPEG big images 

Pagina

 
User defined page size 
Choose one of the predefined standard sizes or select user defined.
Specifies the page size using a standard name or in points (no suffix or ##x##pt), inches (##x##in), centimeters (##x##cm), or millimeters (##x##mm).
Set the target browser width in pixels (400-1200). This determines the page scaling of images.
   2-Sided   Landscape
   
   
   
Specifies the margin size using points (no suffix or ##x##pt), inches (##x##in), centimeters (##x##cm), or millimeters (##x##mm). Keep empty for default value.
Left
Middle
Right
Sets the page header to use on body pages.
Left
Middle
Right
Sets the page footer to use on body pages.

Indice

Sets the number of levels in the table-of-contents. Empty for unlimited levels.
   Numbered headings Check to number all of the headings in the document.
Sets the title for the table-of-contents. Empty for default title.
Left
Middle
Right
Sets the page header to use on table-of-contents pages.
Left
Middle
Right
Sets the page footer to use on table-of-contents pages.

Colors

Enter the HTML color for the body (background).
Enter the image file for the body (background). These file has to be an attachments!
Enter the HTML color for the text.
Sets the color of links.
Enables generation of links in PDF files.

Fonts

Set the default size of text.
Set the spacing between lines of text.
Choose the default typeface (font) of text.
Choose the default typeface (font) of headings.
Set the size of header and footer text.
Choose the font for header and footer text.
Change the encoding of the text in document.
Check to embed font in the output file.

PDF

Controls the initial viewing mode for the document.
Document: Displays only the docuemnt pages.
Outline: Display the table-of-contents outline as well as the document pages.
Full-screen: Displays pages on the whole screen; this mode is used primarily for presentations.
Controls the initial layout of document pages on the screen.
Single: Displays a single page at a time.
One column: Displays a single column of pages at a time.
Two column left/right: Display two columns of pages at a time; the first page is displayed in the left or right column as selected.
Choose the initial page that will be shown.

Security

Check to number all of the headings in the document.
 Versione stampabile   Modify
 Copy   Annotate
Specifies the document permissions.
Specifies the user password to restrict viewing permissions on this PDF document. Empty for no encryption.
Specifies the owner password to control who can change document permissions etc. If this field is left blank, a random 32-character password is generated so that no one can change the document.

Expert

Specify language to use for date and time format.
Shrink code blocks on page.
Show line numbers for code blocks.
Make spaces visable by dots (·) instead of white spaces.
Make line breaks visable by a extra character (¶) at the end.
Enable this feature if you searching for problems or intent to report a bug report

About

Version 2.4.2 (MoinMoin 1.9.7)


MoinMoin - Generate PDF document using HTMLDOC

This action script generate PDF documents from a Wiki site using
the HTMLDOC (http://www.htmldoc.org) software packages which has
to be preinstalled first.

Copy this script in your's MoinMoin action script plugin directory.

Thanks goes to Pascal Bauermeister who initiated the implementaion.
Lot of things changes since then but the idear using HTMLDOC is the
main concept of this implementation.

Please visit the homepage for further informations:
http://moinmo.in/ActionMarket/PdfAction

@copyright: (C) 2006 Pascal Bauermeister
@copyright: (C) 2006-2010 Raphael Bossek <raphael.bossek@solutions4linux.de>
@license: GNU GPL, see COPYING for details

       

Italiano English
Modifica History Actions

unifihotspot

Procedura Obsoleta!

UniFi HotSpot

Con questa breve guida cercherò di spiegare come realizzare un semplice HotSpot Ninux con SplashPage e VPN per instradare il traffico.

Pacchetti necessari

Dopo aver flashato OpenWRT sulla nostra Ubiquiti Unifi, aggiorniamo il repository dei pacchetti e installiamo i seguenti pacchetti

opkg update
opkg install kmod-ipv6 ip tinc tcpdump mini-snmpd olsrd olsrd-mod-dot-draw olsrd-mod-httpinfo olsrd-mod-mdns olsrd-mod-txtinfo olsrd-mod-nameservice

Configurazione Rete

Disabilitare il firewall e abilitare dnsmasq

/etc/init.d/firewall stop
/etc/init.d/firewall disable

/etc/init.d/dnsmasq start
/etc/init.d/dnsmasq enable

Modificare il file /etc/config/network nel seguente modo

config interface loopback
        option ifname   lo
        option proto    static
        option ipaddr   127.0.0.1
        option netmask  255.0.0.0

config interface lan
        option ifname   wlan0
        option proto    static
        option ipaddr   10.xxx.xxx.1
        option netmask  255.255.255.0
        option dns 8.8.8.8

config interface wan
        option ifname   eth0
        option proto    dhcp

config interface vpn
        option proto none
        option ifname ninux

Consultare la pagina Gestione Indirizzi per impostare la subnet del nostro HotSpot.

Nel file /etc/config/wireless modificare le seguenti righe

option disabled 0

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     www.ninux.org
        option encryption none

Configurazione VPN

Passiamo ora alla configurazione della VPN. Iniziamo a configurare tinc seguendo la guida TincVPN

Modifichiamo il file /etc/tinc/ninux/tinc-up nel seguente modo

ip link set dev ninux up
ip a a dev ninux 10.0.1.xxx/24 broadcast 10.0.1.255
#Adjust MTU
ip link set mtu 1280 dev ninux
iptables -A FORWARD -p tcp -m tcp --tcp-flags SYN,RST SYN -j TCPMSS --clamp-mss-to-pmtu
#hotspot
grep relakks /etc/iproute2/rt_tables || echo 200 relakks >> /etc/iproute2/rt_tables
ip rule add from 10.xxx.xxx.0/24 table relakks
ip route add 10.xxx.xxx.0/24 dev wlan0 table relakks
ip route add default via 10.0.1.1 table relakks

Inviare un'email a contatti@ninux.org con le subnet del proprio HotSpot per abilitare il tunnel Relakks.

Abilitare tinc

/etc/init.d/tincd start
/etc/init.d/tincd enable

Configurazione OLSR

Configurare il file /etc/config/olsrd

config 'olsrd'
        option 'IpVersion' '4'

config LoadPlugin
        option 'library' 'olsrd_httpinfo.so.0.1'
        option 'port' '1978'
        list 'Net' '0.0.0.0 0.0.0.0'

config LoadPlugin
        option 'library' 'olsrd_nameservice.so.0.3'

config LoadPlugin
        option 'library' 'olsrd_txtinfo.so.0.1'
        option accept '0.0.0.0'

config 'Interface'
        option 'interface' 'vpn'
        option 'LinkQualityMult' 'default 0.2'

config 'Hna4'
        option 'netaddr' '10.xxx.xxx.0'
        option 'netmask' '255.255.255.0'

config LoadPlugin
        option library 'olsrd_mdns.so.1.0.0'
        option "NonOlsrIf" "lan"

Abilitare olsr

/etc/init.d/olsrd start

/etc/init.d/olsrd enable

Configurazione Splash Page

Per la configurazione della SplashPage seguire la seguente guida Modificare il file di configurazione /etc/nodogsplash/nodogsplash.conf con le seguenti righe

........

GatewayInterface wlan0

........

FirewallRuleSet authenticated-users {

   FirewallRule allow all

}

In questo modo abilitiamo la SplashPage sull'interfaccia wireless dell'HotSpot e abilitamo qualsiasi tipo di traffico verso la rete ninux.

Configurazione miniSNMP

Possiamo configurare il pachetto mini-snmpd per avere delle statistiche sul traffico del nostro HotSpot.

Modifichiamo il file /etc/config/mini_snmpd nel seguente modo

config mini_snmpd
        option enabled 1
        option community public
        option location ''
        option contact ''
        option disks '/tmp,/overlay'
        option interfaces 'wlan0,ninux' # Max 4

Inviare un'email a contatti@ninux.org con le subnet del proprio HotSpot per abilitare le statistiche.